Some image builds not producing logs
Incident Report for Adaptable
Resolved
This incident has been resolved.
Posted Aug 24, 2023 - 22:04 MDT
Monitoring
A workaround for this issue has been implemented while we wait for a fix from the cloud service vendor. We are now monitoring new app deployments to make sure the workaround is sufficient. While this workaround is in effect, the first deploy of an app may take up to 2 extra minutes to deploy.
Posted Aug 24, 2023 - 15:50 MDT
Identified
The underlying issue with the cloud service provider has been identified and we are working on a workaround.
Posted Aug 24, 2023 - 10:41 MDT
Update
Based on our analysis, it appears that this issue only affects newly created apps doing builds in the first several minutes after app creation. Manually triggering an additional deploy should produce build logs. We continue to work with the cloud vendor and our development team to implement a fix.
Posted Aug 23, 2023 - 18:12 MDT
Update
We have traced this to a problem with an underlying cloud service and have engaged the cloud provider. We will provide updates as we receive them from the cloud provider.
Posted Aug 22, 2023 - 16:58 MDT
Investigating
We are currently investigating an issue where some app image builds are not producing output logs. The issue appears to be intermittent, so triggering an additional deploy manually may produce the expected build logs. The issue appears to only affect logs for image builds and not any other logs.
Posted Aug 22, 2023 - 13:20 MDT
This incident affected: App Deploys & Management.