Apps stuck in the deploy-starting state
Incident Report for Adaptable
Resolved
All apps have recovered and should no longer be stuck in a deploying or deploy starting state. Some apps may need to be deployed again manually to deploy the latest GitHub revision or recent configuration changes.
Posted Sep 06, 2023 - 15:10 MDT
Monitoring
A fix has been implemented and apps stuck in the deploy starting state are returning to normal. We anticipate all apps will have been processed and will recover in about the next 30 minutes.
Posted Sep 06, 2023 - 14:21 MDT
Identified
We have root caused the issue and are implementing a fix.
Posted Sep 06, 2023 - 09:29 MDT
Investigating
There was an issue on 9/6/2023 that caused a number of applications to end up stuck in the deploy-starting state. Around this time, the api dashboard was also extremely slow to load. We are investigating the root cause of the issue while also working to clear the queue of apps stuck in the deploy starting state.
Posted Sep 06, 2023 - 08:51 MDT
This incident affected: App Deploys & Management.